XML and Student Reports

My wife is a kindergarten teacher and in Australia, Christmas is the end of our school year and the start our summer break.  However this is also when student reports are due.   The School at which she works is a pretty expensive private school with what appears no lack of IT funding, however for some reason the Kindergarten and Pre-Primary classes are the only 2 classes not on the Schools Reporting system, Maze. 

They have to manually do their reports in using a kludged word document with some macros that one of the IT staff had written the previous year.  From what I could gather they really didn’t work too well and when my stressed out, frustrated and panicking wife asked me to have a look at them with fast approaching deadlines I took one look at them and really wanted to say “Get your IT guys to fix the problem”, however common sense prevailed and got the better of me.

After looking at the word document and querying my wife on her work flow when creating the reports I knew I could do something both easier and quicker than trying to debug the word documents.

Currently the Student reporting work flow is as follows:

  1. Each of the teachers involved in the class has to write a comment for each of the students into a word document for vetting, in the kindergartens instance it involved 4 separate word documents with each of the 25 students comments, one for the class teacher (my wife), then one for the art teacher, music and the principle, all up 4 comments per child x 25 children. 
  2. Once vetted the comments get individually copy and pasted into their relevant fields in the childs report by the class teacher (the kludged word document the IT staff wrote)
  3. Save a copy for each child and then start again for the next report and so on.
  4. When all the reports are created and vetted again they then need to be printed.

Now my wife is IT illiterate at the best of times, but now under the pump to get these reports out with the fast approaching deadline I know I had to do something that worked simply and get it done quickly, or that stress would flow out into our family life.

First of all I created a simple XML Schema that covered the data in student reports.

I then merged all comments into an XML document using Word and the Schema I created, saving as pure XML, no formatting etc

I then used MyEclipse and BIRT to create an XML report using the same format as the original word document.

VIOLA simple reporting system, that took less than a couple of hours to create and now easy to vet, update and run……

……Well sort of…….

After feeling proud of myself for getting it all up and running so quickly I noticed that in the output, it looked like these was some sort of problem with the text wrapping and alignment on certain students and in different comments.  Some reports seemed to have hanging  spaces, commas, and full stops on the left of the data field, i.e. it would wrap the space to the next line, or a comma would start on a new line etc.   The reason I used XML was I didn’t have to worry about the formatting of the comments, I will do all that in my reports.

So I went though all the text wrapping options in BIRT for all the fields, nothing seemed to make a difference….bugger!

Next step I  Googled the problem, one vague reference was found but really didn’t help, I was stuffed.

Last line of resort the night before reports were due, I posted a help request on the MyEclipse support forums,  I sent through a screen shot of an offending report at the request of one of the support staff, I thought yes it will be all sorted soon.  Unfortunately the response from the support staff was, “that they couldn’t find a way to correct it and and have filed an enhancement request with their reports development team”….nooooooooooooooo,I was totally stuffed…..I could feel the cold sweat starting to form…..

In the the end I had to bite the bullet do a less technical solution to my problem which was manually do the text wrapping by hand, pain in the butt, luckily it was not on all student comments, but we got the reports in on time.

And finally as Murphy would have it, 2 days after the reports were hand massaged,  printed and sent out.  MyEclipse released their new version 7.0GA and guess what? It all works perfectly in this version.  It appears the problem was in the earlier version of BIRT that was shipped with MyEclipse 6.5GA.  7.0 is shipped with the latest version.

Similar Posts:

Print Friendly, PDF & Email

Author: Stephen Eaton

Geek at heart. Loves to tinker and find out how things work, which inevitably leads to items in pieces and not working for much longer :)

Leave a Reply